Discontinuité dans le flux

Post Reply
chabriac
WUFI User
WUFI User
Posts: 18
Joined: Mon May 14, 2012 9:56 pm -1100

Discontinuité dans le flux

Post by chabriac » Mon Jul 23, 2012 10:26 pm -1100

Bonjour
j'ai besoin d'un avis concernant des résultats sur WUFI pro 5.1
Je simule un mur de pisé de 50cm. Le rayonnement, la pluie et le vent sont désactivés, Pour le climat intérieur et extérieur, seule la température varie selon une sinusoïde annuelle. En observant les résultats, pour le flux de chaleur de la face intérieure, j'obtiens les résultats suivant (en vert le flux de chaleur, en rouge la température)

Image

Ce que je n'arrive pas à comprendre, ce sont les "sauts" dans la courbe du flux de chaleur, qui créent une discontinuité dans la courbe. Cela semble venir des phénomènes de changement de phase, mais le saut ne semble pas logique, comme si il y avait des valeurs seuils pour l'évaporation ou la vaporisation.
Ces saut sont synchronisés avec le flux de vapeur d'eau.

Merci de me donner votre avis sur ce phénomène. [/url]

Amandine Piot
WUFI International Support Team
WUFI International Support Team
Posts: 38
Joined: Mon Feb 28, 2011 11:02 pm -1100

Post by Amandine Piot » Tue Jul 24, 2012 12:45 am -1100

Bonjour,
le mieux serait peut-être de m'envoyer votre fichier (avant de sauvegarder allez dans Options->données résultats et décochez la case "données du film" pour alléger le fichier).
Il ne devrait pas y avoir de saut dans les flux; est-ce que vous avez des erreurs de convergence ou une différence dans les bilans en humidité (voir dans Sorties -> Statut : dernier calcul, les balances 1 et 2 doivent être très proches) ?

chabriac
WUFI User
WUFI User
Posts: 18
Joined: Mon May 14, 2012 9:56 pm -1100

Post by chabriac » Tue Jul 24, 2012 1:44 am -1100

Aucune erreur de convergence ou de problème de balance
Le fichier est téléchargeable à l'adresse suivante
http://dl.free.fr/m9sjUCMCZ

Merci de votre aide

Amandine Piot
WUFI International Support Team
WUFI International Support Team
Posts: 38
Joined: Mon Feb 28, 2011 11:02 pm -1100

Post by Amandine Piot » Tue Jul 24, 2012 2:21 am -1100

Le problème vient de la résistance thermique en surface: le fait d'utiliser une valeur nulle fausse le calcul du flux en surface. Celui-ci est en effet égal à :
q=(Tair-Tsurface)/Résistance
On a toujours quelque chose proche de "0/0", ce qui est numériquement instable. En théorie, en calcul avec des infiniment petits (dérivées), on peut effectuer le calcul. Mais Wufi utilise des éléments finis pour sa discrétisation spatiale.
Une résistance nulle correspond à un contact parfait entre deux surfaces. Si votre mur est en contact avec l'air, il faut utiliser une valeur non-nulle.

chabriac
WUFI User
WUFI User
Posts: 18
Joined: Mon May 14, 2012 9:56 pm -1100

Post by chabriac » Tue Jul 24, 2012 2:31 am -1100

Effectivement, le problème est résolu
merci de votre aide rapide!

Post Reply